Vulnerability Management. A thread.
I don’t see much written on vulnerability management in more holistic terms vs. patch/bug fixing. This might be ok given a lot of vuln. mgmt. should be contextualized into enterprise risk/control. But still worth a short thread.......
1/13
💻 What to look for on a site with IIS?
1. Use shortscan to search for short (and possibly full) filenames and extensions.
- shortscan : - https://t.co/g2EIuBES1T
2. Check for reverse proxy and try directory traversal:
/backend/ -> 10.0.0.1/api/
/backend/..%2Ftest -> 10.0.0.1/test
- You can read more here :- https://t.co/SGoeW63Rjc
3. When we can get the file expansion, we look at the keys in web.conf and try to get the RCE through deserialization.
- Read about it here :- https://t.co/RjxwZs9GKK
4. Trying to load files .asp , .aspx , .ashx and so on
- Full list here :- https://t.co/2CEhDWrUNj
👀 Check Out Old Tweets Of @TodayCyberNews
#CyberSecurity #bugbountytips #BugBounty #infosec #iis #rce
################################
CVE-2023-38408: Remote Code Execution in OpenSSH's forwarded ssh-agent
################################
now.. first questions...
how many devices in your enterprise do you have running a vulnerable version of SSH?
How many of these are internet facing?
are there in the wild exploitation?
Do you need to patch regardless? (think cyber essentials)
are there even patches available?
At what priority should you patch this vs other vulnerabilities?
#Vulnerability #Management
#7 So what can you do?
▪️Eat saturated fats and cut out seed oils
▪️Limit carbs and sugars
▪️Grow your own food in your self-made compost
▪️Exercise at least 3 times a week
▪️Limit your screen time
▪️Enjoy the sun as much as possible
▪️Read the book 'Turtles All the Way Down'
Lessons Learned From @Hacker0x01's Live Hacking Event (h1-4420)!
Shout outs to @alicanact60, @shm0ul and @ajxchapman for all their help throughout the event!
🎥👉🏼 https://t.co/s4x1qkL2QG
I'm working on a talk and looking for some ideas for port scanning. I'm currently scanning ports 443,8443,8000,5000 across a set of IP addresses. What other ones would you scan and why? 8081? 3000?
#CVE#Hunting#MDE#M365D CVE-2023-21554
Alternative to look only at process events
DeviceProcessEvents
| where Timestamp > ago(30d)
| where ProcessVersionInfoOriginalFileName has "MQSVC"
| summarize by DeviceName
#CVE#Hunting#MDE#M365D
CVE-2023-21554
DeviceNetworkEvents
| where Timestamp > ago(30d)
| where ActionType == "ListeningConnectionCreated"
| where LocalPort == "1801"
| where InitiatingProcessVersionInfoOriginalFileName has "MQSVC"
| summarize by DeviceName
Stanford University offers this free course on Web Security.
The course covers:
1. HTTP, Cookies, Sessions
2. Same Origin Policy
3. Cross-Site Scripting (XSS)
4. Denial-of-service, Phishing, Side Channels
5. WebAuthn
6. Server security
and more...
Link: https://t.co/hFm55j3lYp