There's been a ton of talk about the role of humans in code review, and when and how humans should be signing off on changes.
I believe that, long-term, humans have no role in routinely reviewing code.
New on the Anthropic Engineering Blog: Our tips for developers on using Agent Skills, a new way to extend Claude's capabilities with instruction folders, scripts, and resources:
https://t.co/2liRUo4AWO
Talked with the Claude Code team on how they build Claude Code. It feels I get a peek into the future, and I get why Dario said 6 months ago that 90% of code will be written by AI.
This team works SO differently than any eng team I saw. Will share in-depth soon. One example:
Today, after over 5 years of work, HTTP/3 was finally standardized as RFC 9114! https://t.co/IGMNam0AOS
Together with RFC 9204 (QPACK header compression) and RFC 9218 (Extensible Priorities) it ushers in an important new chapter for the Web!
Proud to have been part of this!
The recording of the Evolutionary Design session of The Art of Agile Development #bookclub is up! It featured @KentBeck and is full of great insights. You don’t want to miss this one. https://t.co/4paLKGYHlf #aoad2#agile@OReillyMedia
"Platform Engineering" is rapidly becoming the new DevOps or SRE. Almost every day we hear about another org building an internal developer platform or control plane.
Want to know what platform engineering is, where the trends are going, and why you should care?
Read on 🧵👇
Another common question I’m answering working with scaling tech companies is…
Q. What’s the worst leadership advice you’ve heard?
A. By far the worst is “Hire great people and get out of their way”.
Let me explain… 🧵 (1/32)
I really enjoyed this paper by neuroscientists @AlexBaria and @doctabarz calling on other neuroscientists to think critically about how their use of the Computational Metaphor (THE BRAIN IS A COMPUTER) feeds #AIhype and harmful deployment of "AI".
https://t.co/qUC2ECHbTh
2021 was our biggest Black Friday Cyber Monday ever! Together with our friends at @GoogleCloud we achieved near-perfect uptime while averaging ~30TB/min of egress traffic across our infrastructure. That’s a massive ~43PB/day!
Here are some of the most interesting stats 🧵👇
"So despite what a leap forward ES6 everywhere, ubiquitous HTTP2, and import maps combine to present, there's clearly still a class of apps that'll need Webpack. Not everyone can take these things out yet, but those who can will be mightily pleased." https://t.co/PUXa1j44wb
The theory is nice when everything is already cached - however even with h2, the initial, non-cached loading perf still degrades linearly as the total number of modules increases.
Now that we’ve announced the React 18 alpha, I’d like to share what I’ve been working on for the past year to give some insight into how research happens on the React Core Team to produce the features you see announced.
🧵
BREAKING: In major copyright battle between tech giants, SCOTUS sides w/ Google over Oracle, finding that Google didnt commit copyright infringement when it reused lines of code in its Android operating system. The code came from Oracle's JAVA SE platform. https://t.co/vAK7jMPa8e
Here’s some mind-blowing technology being developed by @boztank and his team for our AR glasses: wrist-based sensors that let you control devices using the same electrical motor nerve signals you use to move your hands
https://t.co/UsVsGA7tm6
"Spotify is letting employees work from anywhere — while still paying San Francisco and New York salaries" 😍. This is making Twitter and Facebook look awful with their if-you-move-we'll-dunk-your-pay policy. Same remote-capable work, same pay 👏 https://t.co/Ozg5w85Arg